You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

115 lines
3.5 KiB

2 months ago
2 months ago
  1. {
  2. "type": "project",
  3. "license": "proprietary",
  4. "minimum-stability": "dev",
  5. "prefer-stable": true,
  6. "require": {
  7. "php": ">=7.2.5",
  8. "ext-ctype": "*",
  9. "ext-iconv": "*",
  10. "beberlei/doctrineextensions": "^1.3",
  11. "bjeavons/zxcvbn-php": "^1.2",
  12. "cocur/slugify": "^4.0",
  13. "composer/package-versions-deprecated": "1.11.99.1",
  14. "doctrine/annotations": "^1.0",
  15. "doctrine/doctrine-bundle": "^2.2",
  16. "doctrine/doctrine-migrations-bundle": "^3.0",
  17. "doctrine/orm": "^2.8",
  18. "friendsofsymfony/jsrouting-bundle": "^2.7",
  19. "knplabs/doctrine-behaviors": "^2.2",
  20. "knplabs/knp-markdown-bundle": "^1.9",
  21. "knplabs/knp-menu-bundle": "^3.1",
  22. "knplabs/knp-paginator-bundle": "^5.4",
  23. "phpdocumentor/reflection-docblock": "^5.2",
  24. "scheb/2fa-google-authenticator": "^5.7",
  25. "scheb/2fa-qr-code": "^5.7",
  26. "sensio/framework-extra-bundle": "^6.1",
  27. "stof/doctrine-extensions-bundle": "^1.6",
  28. "symfony/apache-pack": "^1.0",
  29. "symfony/asset": "5.2.*",
  30. "symfony/console": "5.2.*",
  31. "symfony/dotenv": "5.2.*",
  32. "symfony/event-dispatcher": "5.2.*",
  33. "symfony/expression-language": "5.2.*",
  34. "symfony/finder": "5.2.*",
  35. "symfony/flex": "^1.3.1",
  36. "symfony/form": "5.2.*",
  37. "symfony/framework-bundle": "5.2.*",
  38. "symfony/http-client": "5.2.*",
  39. "symfony/intl": "5.2.*",
  40. "symfony/mailer": "5.2.*",
  41. "symfony/mime": "5.2.*",
  42. "symfony/monolog-bundle": "^3.1",
  43. "symfony/notifier": "5.2.*",
  44. "symfony/process": "5.2.*",
  45. "symfony/property-access": "5.2.*",
  46. "symfony/property-info": "5.2.*",
  47. "symfony/proxy-manager-bridge": "5.2.*",
  48. "symfony/security-bundle": "5.2.*",
  49. "symfony/serializer": "5.2.*",
  50. "symfony/string": "5.2.*",
  51. "symfony/swiftmailer-bundle": "^3.5",
  52. "symfony/translation": "5.2.*",
  53. "symfony/twig-bundle": "^5.2",
  54. "symfony/validator": "5.2.*",
  55. "symfony/web-link": "5.2.*",
  56. "symfony/webpack-encore-bundle": "^1.11",
  57. "symfony/yaml": "5.2.*",
  58. "twig/extra-bundle": "^2.12|^3.0",
  59. "twig/twig": "^2.12|^3.0"
  60. },
  61. "require-dev": {
  62. "symfony/browser-kit": "^5.2",
  63. "symfony/css-selector": "^5.2",
  64. "symfony/debug-bundle": "^5.2",
  65. "symfony/maker-bundle": "^1.0",
  66. "symfony/phpunit-bridge": "^5.2",
  67. "symfony/stopwatch": "^5.2",
  68. "symfony/var-dumper": "^5.2",
  69. "symfony/web-profiler-bundle": "^5.2"
  70. },
  71. "config": {
  72. "optimize-autoloader": true,
  73. "preferred-install": {
  74. "*": "dist"
  75. },
  76. "sort-packages": true
  77. },
  78. "autoload": {
  79. "psr-4": {
  80. "App\\": "src/",
  81. "App\\Core\\": "core/"
  82. }
  83. },
  84. "autoload-dev": {
  85. "psr-4": {
  86. "App\\Tests\\": "tests/"
  87. }
  88. },
  89. "replace": {
  90. "symfony/polyfill-ctype": "*",
  91. "symfony/polyfill-iconv": "*",
  92. "symfony/polyfill-php72": "*"
  93. },
  94. "scripts": {
  95. "auto-scripts": {
  96. "cache:clear": "symfony-cmd",
  97. "assets:install %PUBLIC_DIR%": "symfony-cmd"
  98. },
  99. "post-install-cmd": [
  100. "@auto-scripts"
  101. ],
  102. "post-update-cmd": [
  103. "@auto-scripts"
  104. ]
  105. },
  106. "conflict": {
  107. "symfony/symfony": "*"
  108. },
  109. "extra": {
  110. "symfony": {
  111. "allow-contrib": false,
  112. "require": "5.2.*"
  113. }
  114. }
  115. }