Browse Source

Support Ruby 2.2.0 and 2.3.0

Judging from the test suite, the only issue in supporting Ruby 2.2.0+
was with the `mysql2` gem. Updating this to the latest 0.3.x allows
Lobsters to run with newer Rubies.

We can't update to the absolute latest `mysql2` gem without first
updating Rails, which is why I used the pessimistic version constraint
for `mysql2`.
master
Derek Prior 4 years ago
parent
commit
6eec2e26af
No known key found for this signature in database GPG Key ID: 60D9C7F1019704B4
2 changed files with 3 additions and 3 deletions
  1. +1
    -1
      .ruby-version
  2. +2
    -2
      Gemfile.lock

+ 1
- 1
.ruby-version View File

@@ -1 +1 @@
1.9.3-p429
2.3.0

+ 2
- 2
Gemfile.lock View File

@@ -56,7 +56,7 @@ GEM
mime-types (2.6.1)
mini_portile (0.5.3)
minitest (5.7.0)
mysql2 (0.3.16)
mysql2 (0.3.20)
nokogiri (1.6.1)
mini_portile (~> 0.5.0)
oauth (0.4.7)
@@ -147,4 +147,4 @@ DEPENDENCIES
unicorn

BUNDLED WITH
1.10.6
1.11.2

Loading…
Cancel
Save